ARMA 3 Launcher Failing? This May Be Your Fix.

Discussion Related to the ARMA 3 Server and ARMA 3 in General.
User avatar
Posts: 265
Joined: Fri Jan 16, 2015 5:49 pm

ARMA 3 Launcher Failing? This May Be Your Fix.

Postby yurisuika » Sat May 21, 2016 12:33 pm

Well for a few months I suffered with a launcher that wouldn't open, then after an update a launcher that would close after 10 seconds.


Why would it allow me to use the launcher without issue for 10 seconds, then freeze the window and come up with an error saying it could not even start? It made no sense.

I had gone through the logs and tried to search for answers, but nothing would turn up for this crash.

Code: Select all

2016-05-21 11:38:04,552 [FATAL]   1: ShellWindow [Launcher.MainWindow+<HandleWindowLoaded>d__10.MoveNext:0] System.NotImplementedException: The method or operation is not implemented.
   at MS.Internal.AppModel.ITaskbarList.HrInit()
   at System.Windows.Window.ApplyTaskbarItemInfo()
   at System.Windows.Window.OnTaskbarItemInfoChanged(DependencyPropertyChangedEventArgs e)
   at System.Windows.Window.<.cctor>b__2(DependencyObject d, DependencyPropertyChangedEventArgs e)
   at System.Windows.DependencyObject.OnPropertyChanged(DependencyPropertyChangedEventArgs e)
   at System.Windows.FrameworkElement.OnPropertyChanged(DependencyPropertyChangedEventArgs e)
   at System.Windows.DependencyObject.NotifyPropertyChange(DependencyPropertyChangedEventArgs args)
   at System.Windows.DependencyObject.UpdateEffectiveValue(EntryIndex entryIndex, DependencyProperty dp, PropertyMetadata metadata, EffectiveValueEntry oldEntry, EffectiveValueEntry& newEntry, Boolean coerceWithDeferredReference, Boolean coerceWithCurrentValue, OperationType operationType)
   at System.Windows.DependencyObject.SetValueCommon(DependencyProperty dp, Object value, PropertyMetadata metadata, Boolean coerceWithDeferredReference, Boolean coerceWithCurrentValue, OperationType operationType, Boolean isInternal)
   at System.Windows.DependencyObject.SetValue(DependencyProperty dp, Object value)
   at Launcher.MainWindow.<HandleWindowLoaded>d__10.MoveNext()

I knew it stopped working shortly after I had reinstalled some Adobe software with Visual C++ updates, but after trying to reinstall them many times, I simply didn't know what was wrong. I tried reinstalling the game entirely, deleting all ARMA no avail...

Oddly enough, it turns out that one of those Visual C++ updates was the issue. But it wasn't in need of a reinstall. It was in need of an UNINSTALL! For some reason, Visual C++ 2012 is the culprit. So, if you have this issue like I did, check your program list for it. Into the trash it goes! Right?

However, this causes programs that need MSVCR/MSVCP110.dll (2012) to not work, such as Adobe CC. So how do we get out of this conundrum? ARMA 3 uses the MSVCR/MSVCP120.dll (2013), so it doesn't seem to leave any option other than pick and choose...


Additionally, Visual C++ 2013 is the one required by the launcher, so don't remove that!

♡ yuri

Return to “ARMA 3”

Who is online

Users browsing this forum: No registered users and 5 guests