Can't Join Server....Help!

Discussion Related to the ARMA 3 Server and ARMA 3 in General.
Posts: 28
Joined: Fri Sep 25, 2015 4:06 pm

Can't Join Server....Help!

Postby Peabot » Tue Jul 12, 2016 8:18 am

I spent the better part of this morning trying to get on the server...

Apparently I don't have the right mods, since CBA_3 and the Extended Mod Pack mods are labeled RED in the server search lobby. I have unsubscribed and subscribed to them 3 times now, but to no avail.

Miraculously I was able to get on to the information area WITHOUT some of the mods, and I was able to talk to the one other player and he said he had some problem but went to ArmAHolic to download CBA and that fixed it...but that didn't fix it for me.

Besides, if I use the Steam Launcher doesn't whatever version i have locally sync with the Steam version?

I have today off and was looking forward to some ArmA-ing so a little bummed. I really have not clue what is wrong...

Posts: 28
Joined: Fri Sep 25, 2015 4:06 pm

Re: Can't Join Server....Help!

Postby Peabot » Tue Jul 12, 2016 8:46 am


While I was writing this with my launcher open, it updated also CUP Weapons, CUP Units, and CUP Vehicles. And after the update...

...Now those MODS are also labeled RED in the server searching lobby...

Posts: 28
Joined: Fri Sep 25, 2015 4:06 pm

Re: Can't Join Server....Help!

Postby Peabot » Tue Jul 12, 2016 9:02 am

Just a thought I had while doing all this: The MODS on the Server Search Lobby (or whatever that is called....) all have version numbers on them, while the (supposedly) corresponding MODS in the Steam Workshop and in the Launcher MOD pane don't, so it's hard to tell if I have the right version or not. In some cases the titles are different altogether. For example CBA_A3 is the name of that MOD in Steam and in the Launcher, but in the Servers Search Lobby it's called Community Base Addon v2.4.1. I had CBA_A3 in the Launcher up till now and it worked fine until last night, so I'm assuming the name difference, if it has been fine till now, is not the problem, however it's still nice to be able to tell at a glance if the Version that is called for by the server is the version that I have in the launcher....

Posts: 103
Joined: Sun Sep 21, 2014 11:37 pm
Location: Puyallup, WA

Re: Can't Join Server....Help!

Postby Brent » Tue Jul 12, 2016 11:10 am

Odd, I just use the Arma Launcher and haven't had any issues with versions. It should automatically update if you're using steam.

I've seen lots of complaints about the launcher, but it's honestly one of the easiest things to navigate through in my opinion.

Sounds like your Arma wasn't synced or finished downloading the most recent patch for Tanoa yesterday, might be why your options were red.

Posts: 28
Joined: Fri Sep 25, 2015 4:06 pm

Re: Can't Join Server....Help!

Postby Peabot » Tue Jul 12, 2016 11:54 am

I wrote down everything the pop-up window told me is wrong with my files. It says that my vehicle files in the CUP Vehicles MOD have different signatures than the server, and that I need to add valid signatures or delete those files. I deleted those files, but then when I came back it listed the next 6 vehicles out of the same place....basically it probably will eventually tell me all the files have wrong signatures...and then it might also be the CUP units or the CUP weapons.

Before I did all this I deleted ALL MODS and reinstalled them from Steam using the launcher.

So now short of uninstalling ArmA altogether and reinstalling from scratch I have no idea what I can do.

Everything was working fine until today. I was able to play yesterday AFTER the Apex update...


Posts: 45
Joined: Sun Apr 05, 2015 7:50 pm

Re: Can't Join Server....Help!

Postby MysticDaedra » Tue Jul 12, 2016 3:23 pm

Have you tried verifying the cache integrity through steam? This solve many problems. The only thing that a clean install will do that verifying the cache won't is fixing registry errors, which I doubt is the problem here. Give that a try.

User avatar
Posts: 33
Joined: Sun Feb 09, 2014 1:30 pm
Location: San Francisco Ca.

Re: Can't Join Server....Help!

Postby Fresh » Tue Jul 12, 2016 6:52 pm

Same thing happened to me last night when i tried joining the test server with Tanoa, one of the mods was 'red', CBA etc...i made sure to check the integrity of the game by going into Steam properties, and when that was all done, (nothing seemed amiss), i went back to the 'launcher' and selected 'ignore' for that one mod and it worked.

I was all by myself on the server for a good while and so far i love the new island, very different.

User avatar
Posts: 25
Joined: Mon Nov 17, 2014 3:56 pm
Location: Vancouver, BC

Re: Can't Join Server....Help!

Postby JonesB » Tue Jul 12, 2016 7:36 pm

CBA_A3 updated at 1030 pm pst last night. Omon said new version should be uploaded to the server next restart.

Edit - Looks like all mods are following suite. Might not be able to join for a couple of days until mods updates are all released and server is updated.

Posts: 10
Joined: Sat Apr 30, 2016 11:52 am

Re: Can't Join Server....Help!

Postby blubFisch » Wed Jul 13, 2016 1:30 pm

Another CBA update, can't join the new server atm

User avatar
Site Admin
Posts: 447
Joined: Sun Jan 12, 2014 5:12 pm
Location: Renton, WA

Re: Can't Join Server....Help!

Postby omon » Wed Jul 13, 2016 2:19 pm

blubFisch wrote:Another CBA update, can't join the new server atm

Yep i know, waiting for few more mission edits then updating it!
Maybe another hour or two!

Return to “ARMA 3”

Who is online

Users browsing this forum: No registered users and 3 guests